[Webkit-unassigned] [Bug 43993] Add idl and mock classes for FileSystem API's {File, Directory}Entry and related interfaces
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Aug 13 17:33:31 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=43993
Dumitru Daniliuc <dumi at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #64380|review? |review-
Flag| |
--- Comment #2 from Dumitru Daniliuc <dumi at chromium.org> 2010-08-13 17:33:31 PST ---
(From update of attachment 64380)
WebCore/ChangeLog:14
+ * WebCore.xcodeproj/project.pbxproj:
you need to add these new files to a whole lot more build files (and possibly JSDerivedSources too): see http://trac.webkit.org/changeset/61531
WebCore/storage/DirectoryEntry.cpp:54
+ // FIXME: to be implemented.
might be worth adding ASSERT_NOT_REACHED() to all methods that are not yet implemented.
WebCore/storage/DirectoryEntry.idl:38
+ void getFile(in DOMString path, in [Optional] Flags options, in [Optional, Callback] EntryCallback successCallback, in [Optional, Callback] ErrorCallback errorCallback);
will "[Optional] Flags options" generate "RefPtr<Flags> options;" or just "Flags* options"?
r- mostly because of the changes required to other build files.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list