[Webkit-unassigned] [Bug 43276] Implements IDBKeyPath extractor.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 10 09:38:11 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43276


Marcus Bulach <bulach at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #63638|0                           |1
        is obsolete|                            |




--- Comment #16 from Marcus Bulach <bulach at chromium.org>  2010-08-10 09:38:10 PST ---
Created an attachment (id=64017)
 --> (https://bugs.webkit.org/attachment.cgi?id=64017)
Patch

(this is still blocked by https://bugs.webkit.org/show_bug.cgi?id=42976)

more inline:

(In reply to comment #15)
> (From update of attachment 63638 [details])
> WebKit/chromium/src/WebIDBKeyPath.cpp:34
>  +  #include "Vector.h"
> <wtf/Vector.h>
done.

> 
> WebKit/chromium/src/WebIDBKeyPath.cpp:36
>  +  using WebCore::IDBKeyPathElement;
> Just using WebCore;
done.

> 
> WebKit/chromium/src/WebIDBKeyPath.cpp:51
>  +      delete m_private;
> maybe check to see if m_private is !0...and then set it to 0?
I used your suggestion and created a WebPrivateOwnPtr that takes care of it.

> 
> WebKit/chromium/public/WebIDBKeyPath.h:53
>  +      void assign(WTF::Vector<WebCore::IDBKeyPathElement, 0>&);
> typically we just make these all implicit conversions.  Is that not possible?
changed so that there's a factory method, in order to capture any parsing errors.

> 
> WebKit/chromium/public/WebIDBKeyPath.h:58
>  +      WTF::Vector<WebCore::IDBKeyPathElement, 0>* m_private;
> I just asked hans to make a PrivateOwnPtr class (like PrivatePrt..maybe renaming it to PrivateRefPtr) for something similar.  Coordinate between yourselves?

good idea! done.

> 
> WebKit/chromium/public/WebIDBKeyPath.h:32
>  +  namespace WebCore {
> #if WEBKIT_IMPLEMENTATION
hmm, I think such forward declarations are required regardless of which side?

> 
> WebKit/chromium/public/WebIDBKeyPath.h:61
>  +  void WebIDBParseKeyPath(const WebString&, WebIDBKeyPath*, int* error);
> Do we have other base methods like this?  Maybe it should be a static method of some class?
yep, created a factory method on WebIDBKeyPath.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list