[Webkit-unassigned] [Bug 36171] [QT] QtWebKit doesn't support NPAPI for DirectFB

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 5 11:20:31 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=36171


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #63608|review?                     |review-
               Flag|                            |




--- Comment #24 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-08-05 11:20:31 PST ---
(From update of attachment 63608)
WebCore/bridge/npapi.h:92
 +  #if defined(XP_UNIX) && !defined(XP_DFB)
Doesn't this have to be upstreamed to npapi.h etc used by Mozilla? I think these headers are copied from mozilla, though I might be wrong.

WebCore/plugins/PluginView.cpp:366
 +  #if defined(XP_X11) && !defined(XP_DFB)
You are chaning a XP_UNIX to XP_X11, are you sure that is right? I guess XP_UNIX is true on mac.

WebCore/plugins/qt/PluginViewQtDFB.cpp:27
 +  #include "PluginViewQtDFB.h"
I guess PluginViewDFBQt would have made more sense

WebCore/plugins/qt/PluginViewQtDFB.cpp:48
 +  extern Q_GUI_EXPORT IDirectFBSurface* qt_directfb_surface_for_pixmap(const QPixmap &pixmap);
& is wrongly aligned

WebCore/plugins/qt/PluginViewQtDFB.cpp:51
 +  namespace WebCore {
Add a newline after this

WebCore/plugins/qt/PluginViewQtDFB.cpp:52
 +  void PluginViewQtDFB::clearWindowInfo(PluginViewQtDFB::DFBWindowInfo *windowInfo)
* is wrongly algined

WebCore/plugins/qt/PluginViewQtDFB.cpp:63
 +                                           const DFBWindowInfo& windowInfo)
put the function definition on one line

WebCore/plugins/qt/PluginViewQtDFB.cpp:64
 +      : m_pluginView(pluginView), m_dfbSurface(0), m_installedEventFilter(false), m_dfbWindowInfo(windowInfo)
Put these on separate lines starting with ,

WebCore/plugins/qt/PluginViewQtDFB.cpp:106
 +  void PluginViewQtDFB::paint(GraphicsContext* context, const IntRect& rect)
a bit of newlines in this method would be nice, grouping the related things together

WebCore/plugins/qt/PluginViewQtDFB.cpp:127
 +  bool PluginViewQtDFB::dispatchEvent(const KeyboardEvent* event)
Here as well. This code is hard reading

WebCore/plugins/qt/PluginViewQtDFB.cpp:145
 +      case Qt::Key_Backspace:
Can't this be moved to another method? It can always be inline

WebCore/plugins/qt/PluginViewQtDFB.cpp:724
 +      case FocusIn: window.type = DWET_GOTFOCUS; break;
dont put  this on one line

WebCore/plugins/qt/PluginViewQtDFB.cpp:731
 +  bool PluginViewQtDFB::eventFilter(QObject* , QEvent* e)
We normally abbriviate event with 'ev'

WebCore/plugins/qt/PluginViewQtDFB.h:40
 +  class KeyboardEvent;
Add a newline after this

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list