[Webkit-unassigned] [Bug 43453] [chromium] The chromium API needs a WebMouseEvent class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 4 01:04:16 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43453


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #63402|review?                     |review-
               Flag|                            |




--- Comment #5 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-08-04 01:04:17 PST ---
(From update of attachment 63402)
Yeah, WebMouseEvent2 is obviously not going to cut it.  We probably should
rename the subclasses of WebInputEvent.  That way we don't have to change
our convention of using WebFoo for DOM thingies named Foo.  MouseEvent
should map to WebMouseEvent given that convention.

Maybe inner classes?  WebInputEvent::{Generic,Mouse,Wheel,Keyboard}?  The
downside to such a solution is that it forces the inclusion of WebInputEvent.h
in places that could previously just forward declare it.  We could also
try to do something using a union:

  struct WebInputEvent {
    enum {...} type;
    ... other common fields ...
    union {
      struct {
        ...
      } mouse;
      struct {
        ...
      } wheel;
      struct {
        ...
      } keyboard;
    } data;
  };

Then it would still be valid to forward declare 'struct WebInputEvent'.

I need to think about this more, but those are some ideas...

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list