[Webkit-unassigned] [Bug 43436] Simple diffs for ~5% complex layout speedup

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 3 11:56:24 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43436


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #63357|review?                     |review+
               Flag|                            |




--- Comment #3 from Darin Adler <darin at apple.com>  2010-08-03 11:56:24 PST ---
(From update of attachment 63357)
This looks good.

> -        RetainPtr<CFMutableDataRef> m_coreTextIndicesData;
> +        Vector<CFIndex, 64> m_coreTextIndicesVector;

Maybe m_coreTextIndicesStorage would be a better name? Or m_coreTextIndicesBuffer? The name should communicate the fact that we should access this through the m_coreTextIndices pointer and not directly.

> +    m_coreTextIndicesVector.reserveCapacity(m_stringLength);

Since this is always used on a new vector, you could use reserveInitialCapacity for slightly better performance.

r=me without additional changes, but you might want to do one of the improvements above. If you decide not to do either improvement, please let a committer know so they can set commit-queue+ on the bug.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list