[Webkit-unassigned] [Bug 38220] [chromium] Add API for querying whether a WebWidget is using GPU accelerated compositing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 30 15:10:10 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38220





--- Comment #6 from Vangelis Kokkevis <vangelis at chromium.org>  2010-04-30 15:10:09 PST ---
There's a semantic difference that I'm trying to capture here which I think
it's important. What this API call is supposed to return is not whether the
accelerated compositing feature is enabled by the user but whether it's
actually active for that page. It seems that most (if not all) of the
is*Enabled() calls currently reflect a mode entered into at the request of the
user.

This is based on my little experience with existing code. I'll rely on
judgement.



(In reply to comment #5)
> I suggested is*Enabled because that is how we have been expressing things like
> this in the webkit api today:
> 
> WebKit/chromium/public> grep 'is.*Enabled' *
> WebAccessibilityObject.h:    bool isEnabled() const;
> WebContextMenuData.h:    bool isSpellCheckingEnabled;
> WebFormControlElement.h:    WEBKIT_API bool isEnabled() const;
> WebFrame.h:    virtual bool isViewSourceModeEnabled() const = 0;
> WebFrame.h:    virtual bool isCommandEnabled(const WebString&) const = 0;
> WebFrame.h:    virtual bool isContinuousSpellCheckingEnabled() const = 0;
> WebGraphicsContext3D.h:    virtual bool isEnabled(unsigned long cap) = 0;
> WebInputElement.h:        WEBKIT_API bool isEnabledFormControl() const;
> WebRuntimeFeatures.h:    WEBKIT_API static bool isDatabaseEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isLocalStorageEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isSessionStorageEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isMediaPlayerEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isSocketsEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isNotificationsEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isApplicationCacheEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isGeolocationEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isIndexedDatabaseEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isWebGLEnabled();
> WebRuntimeFeatures.h:    WEBKIT_API static bool isPushStateEnabled(bool);
> WebRuntimeFeatures.h:    WEBKIT_API static bool isTouchEnabled();
> WebViewClient.h:    virtual bool isSmartInsertDeleteEnabled() { return true; }
> WebViewClient.h:    virtual bool isSelectTrailingWhitespaceEnabled() { return
> true; }
> 
> I agree that isUsingAcceleratedCompositing is better than
> isAcceleratedCompositing, but since this is just bikeshed territory, I lean
> toward matching existing conventions.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list