[Webkit-unassigned] [Bug 38064] Refactoring: RenderBox::calcHeight() could look better

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 24 09:27:06 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=38064





--- Comment #2 from Darin Adler <darin at apple.com>  2010-04-24 09:27:06 PST ---
(From update of attachment 54201)
>          if (hasOverrideSize() && parent()->isFlexibleBox() && parent()->style()->boxOrient() == VERTICAL
> -                && parent()->isFlexingChildren())
> -            h = Length(overrideSize() - borderAndPaddingHeight(), Fixed);

>          if (hasOverrideSize() && parent()->isFlexibleBox() && parent()->style()->boxOrient() == VERTICAL
> +            && parent()->isFlexingChildren()) {
> +            heightResult = overrideSize();

The extra indent here to make sure that the "&&" does not line up with the body
of the if statement is something I often do intentionally. I'm not sure if our
style guide has anything to say about this, but I think it's harder to read
when lined up the way the new code is.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list