[Webkit-unassigned] [Bug 34686] [Haiku] Improve MIME type data base implementation on Haiku

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 12 23:27:54 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=34686


David Levin <levin at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #53112|review?                     |review-
               Flag|                            |




--- Comment #5 from David Levin <levin at chromium.org>  2010-04-12 23:27:54 PST ---
(From update of attachment 53112)
r- for struct name change (and the fact that I can't get you to change it on
landing).


>  2010-04-10  Adam Barth  <abarth at webkit.org>
>  
>          Unreviewed.  Rename m_forceSandboxFlags to m_forcedSandoxFlags, as
> Index: WebCore/platform/haiku/MIMETypeRegistryHaiku.cpp

> -static const ExtensionMap extensionMap [] = {
> +static const ExtensionMap sExtensionMap[] = {

Please don't change the name of this struct. WebKit doesn't use this style of
notation for static const arrays.


> +    // Try system mime database
Please add a "."

> +    String fakeFileName("filename.");
> +    fakeFileName.append(str);
> +
> +    BMimeType type;
> +    if (BMimeType::GuessMimeType(fakeFileName.utf8().data(), &type) == B_OK)

Mild concern about passing untrusted data (derived from ext) to system api, but
since it is a a null terminated string, this appears fine.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list