[Webkit-unassigned] [Bug 37220] Adding static method zeroPoint to class IntPoint.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 7 12:41:48 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=37220


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #52757|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Darin Adler <darin at apple.com>  2010-04-07 12:41:48 PST ---
(From update of attachment 52757)
If it's a class member, then it's IntPoint::zeroPoint(), which is worse than
IntPoint(). I think we either need it to be:

    inline IntPoint zeroIntPoint() { return IntPoint(); }

Or:

    static IntPoint zero() { return IntPoint(); }

So we don't repeat the word point twice.

I also think we should do this for FloatPoint too.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list