[Webkit-unassigned] [Bug 37060] List item markers are not always updated after changes in the DOM

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 5 08:42:03 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=37060





--- Comment #10 from Jakub Wieczorek <jwieczorek at webkit.org>  2010-04-05 08:42:02 PST ---
(In reply to comment #7)
> Huh? The old code says if there is a node, then call enclosingList, walking up
> the DOM tree, and don't go up the render tree at all. The new code does not do
> that. We can debate that later if needed when we try to land this change, I
> guess.

I'm not sure I am following. This loop:

while (renderer && !renderer->node())
    renderer = renderer->parent();

will execute 0 times when the renderer has a node attached to it, which will
bring us to:

Node* node = renderer->node();
if (isList(node))
    return node;
return enclosingList(node);

so basically it's the same code, just formulated in a different way.

> > Anyway, I'll just revert
> > this hunk as it's not even necessary for this patch.
> 
> All we need to land this is a test case demonstrating what the code change
> fixes.

The thing is it was not supposed to fix anything. It was just an unnecessary
cleanup. I should have been more clear about it before.

> > I changed it to be a for loop but personally I don't find it easier to read as
> > we're ending up with something like:
> > 
> > if (child->node() && isList(child->node())) {
> >     // We've found a nested, independent list: nothing to do here.
> >     child = child->nextInPreOrderAfterChildren(list)->previousInPreOrder();
> >     continue;
> > }
> 
> Yes, that's not good. You should not let it be like that! Lets go back to the
> way you have it.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list