[Webkit-unassigned] [Bug 27968] [HTML5][Forms] <input type=number> UI

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 23 15:42:28 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=27968


David Levin <levin at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #39540|review?                     |review-
               Flag|                            |




--- Comment #17 from David Levin <levin at chromium.org>  2009-09-23 15:42:27 PDT ---
(From update of attachment 39540)
Quick pass with some things to fix. 

Please take each comment as something to look for throughout the patch (as
things usually occur more than once).

Your changelog seems a bit sparse.
Please remove commented out code.
Please remove printf's.

>+ Test for the spin control behavior in a type=numnber input.
typo: numnber

> + #define EPSILON (16.0 * std::numeric_limits<double>::epsilon())

Why is this a define instead of a const double? Also epsilon doesn't seem like
the right name since it is 16 * epsilon.

> + void HTMLInputElement::stepUpFromUI(int n)
"n" A more meaningful variable name would be better.


> + void paintBoxDecorationsWithSize(PaintInfo&, int, int, int, int);

Don't include parameter names if they don't add information but in this case
the names for the int parameters would add a lot of information.

This occurs in several places but I just picked out one.

> + // Center the spin button vertically, and move it to the right
Finish sentences with "."

> + const MouseEvent* mevt = static_cast<MouseEvent*>(evt);
"mevt" Use whole words.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list