[Webkit-unassigned] [Bug 29148] replace platform time code with WTF::currentTime()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 11 11:41:50 PDT 2009


Joe Mason <joe.mason at torchmobile.com> changed:

           What    |Removed                     |Added
                 CC|                            |joe.mason at torchmobile.com

--- Comment #4 from Joe Mason <joe.mason at torchmobile.com>  2009-09-11 11:41:50 PDT ---
I believe that in the current codebase, currentTime() is only ever used to
check relative times, even though the descriptions specifies that it should
return seconds since the Unix epoch.  That could let ports take shortcuts by
implementing it to return seconds since some other epoch, or since the system
boot, or whatever's easiest for them.  

I don't know if any ports actually DO take such shortcuts, but this should be
double-checked if this patch is landed.

I was about to suggest renaming currentTime and changing the description to
make it clear the way it was actually used, but I like this approach better. 
No need to duplicate code.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list