[Webkit-unassigned] [Bug 29108] New: eventSender.dragMode needs a better name

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 9 14:54:30 PDT 2009


           Summary: eventSender.dragMode needs a better name
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: Mac OS X 10.5
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: eric at webkit.org
                CC: ap at webkit.org

eventSender.dragMode needs a better name

>From correspondence with Alexey:

Eric: Is dragMode/replayEvents needed for all drags which start inside a
WebView?  On all platforms?  Or only on drags which start inside a WebView and
are dragged outside of the WebView? (if that's even possible in DRT...)

Alexey: When introduced in r17574, replayEvents was used to test HTML drags
(within a WebView, possibly across frames). I do not know whether we have any
tests for dragging out of WebView - if we do, they'd have to use this or
another similar mechanism. No idea about other platforms - it should be easy to
check what EventSenderController does there.

I still don't really understand what cases do and don't want dragMode.  But we
need to document those, and make the toggle have a nice name to reflect what it

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list