[Webkit-unassigned] [Bug 29034] ARM compiler does not understand reinterpret_cast<void*>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 8 13:03:26 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=29034





--- Comment #9 from Darin Adler <darin at apple.com>  2009-09-08 13:03:26 PDT ---
(From update of attachment 39190)
These are all casts that convert a function pointer into a void*. It's not
really a reinterpret_cast issue, but rather the need for a way to convert
function pointers to a single type (specifically, void*, I guess, but it might
work to use some generic function pointer type instead).

I'd prefer that we come up with a way of doing this other than sprinkling the
C-style casts in -- something easier to search for later. Maybe a template
function like this:

    template <typename T> void* function_pointer_cast(T functionPointer) {
return (void*)functionPointer; }

And then later we could change it to work only with function pointers if we can
get that to happen. Not sure about the name, but I'd like to avoid having to
modify so many different sites to deal with this.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list