[Webkit-unassigned] [Bug 28095] [WINCE] W3C Geolocation backend
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 1 18:05:56 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=28095
Adam Barth <abarth at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #34370|review?, commit-queue? |review-
Flag| |
--- Comment #18 from Adam Barth <abarth at webkit.org> 2009-09-01 18:05:56 PDT ---
(From update of attachment 34370)
+ WAIT_OBJECT_0 + 1
This is super ugly. Can we use enums to remove these magical constants?
+ m_selfRef = 0;
RefPtr is not designed to be use across threads like this. I'm also not sure
if GeolocationServiceThread::~GeolocationServiceThread can close those handles
on a random thread.
+ domTimeStamp -= 0x19db1ded53e8000
+ domTimeStamp /= 10000000
Magic constants are the devil.
+ WNDCLASS wcex = {0};
This and the following lines are not proper style.
+ GeolocationServiceWince.h
One class per file, please.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list