[Webkit-unassigned] [Bug 30538] Replace boolean operator indentation example with an if statement.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 19 17:17:53 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=30538


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |darin at apple.com




--- Comment #5 from Darin Adler <darin at apple.com>  2009-10-19 17:17:53 PDT ---
I specifically chose a return statement rather than an if statement, because of
the problem where the boolean operator lines end up lined up with the statement
in the body of the if.

In the past we have discussed indenting one additional level to avoid that
problem, but this was contentious enough that I wanted to leave it out until we
discussed it.

I am *not* sure that what you checked in here represents our style
recommendation, and I wish we had some discussion of it before it was landed!

I would write:

    if (a
            || b)
        return;

Not:

    if (a
        || b)
        return;

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list