[Webkit-unassigned] [Bug 30288] New: jsc scripts cleanup and Qt/GTK fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 11 16:13:15 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=30288

           Summary: jsc scripts cleanup and Qt/GTK fix
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: All
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Tools / Tests
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: oszi at inf.u-szeged.hu


In jsc scripts there are unnecessary code duplications:

- sub jscPath($)
We should move it to webkitdirs.pm.

-my $productDir = productDir();
-
-$productDir .= "/JavaScriptCore" if isQt();
-$productDir .= "/Programs" if isGtk();
Additionally sunspider-compare-results there is a code like this,
but not works with GTK port: $productDir .= "/JavaScriptCore" if (isQt() or
isGtk());
We should use only one function instead of duplicated code.
With Qt port on Windows $productDir must contain the configuration
(release/debug) too.
I propose adding a new function to webkitdirs.pm:
+sub jscProductDir
+{
+    my $productDir = determineConfigurationProductDir();
+    $productDir .= "/JavaScriptCore" if isQt();
+    $productDir .= "/$configuration" if (isQt() && isWindows());
+    $productDir .= "/Programs" if isGtk();
+
+    return $productDir;
+}

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list