[Webkit-unassigned] [Bug 29987] Refactor RenderThemeChromiumMac and RenderThemeChromiumSkia to render media controls using GraphicsContext.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 7 08:18:48 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=29987


Eric Carlson <eric.carlson at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #40752|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #10 from Eric Carlson <eric.carlson at apple.com>  2009-10-07 08:18:48 PDT ---
(From update of attachment 40752)

> +HTMLMediaElement* parentMediaElement(RenderObject* o)
> +{
> +    Node* node = o->node();
> +    Node* mediaNode = node ? node->shadowAncestorNode() : 0;
> +    if (!mediaNode || (!mediaNode->hasTagName(HTMLNames::videoTag) && !mediaNode->hasTagName(HTMLNames::audioTag)))
> +        return 0;
> +
> +    return static_cast<HTMLMediaElement*>(mediaNode);

I suggest naming this "toParentMediaElement" to match the pattern used
elsewhere in WebCore (toInputElement, toRenderXXXX, etc). This file seems like
the right place for the function.


> +class RenderMediaControlsChromium {
> +public:
> +    static bool shouldRenderMediaControlPart(ControlPart part, Element* e);

Don't need the parameter names here.

r=me with these minor changes.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list