[Webkit-unassigned] [Bug 31415] [v8] do not copy data twice when converting short v8 string into WebCore::String

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 25 15:21:00 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=31415





--- Comment #12 from anton muhin <antonm at chromium.org>  2009-11-25 15:21:00 PST ---
(In reply to comment #10)
> (From update of attachment 43080 [details])
> > Index: WebCore/bindings/v8/V8Binding.cpp
> 
> > +template <class S> struct StringTraits
> > +{
> > +    static S getFromResource(WebCoreStringResource* resource);
> > +
> > +    static S convertFromV8(v8::Handle<v8::String> v8String, int length);
> 
> how about naming these fromStringResource and fromV8String?

Done.

> > +template<>
> > +struct StringTraits<String>
> > +{
> > +    static String getFromResource(WebCoreStringResource* resource) {
> > +        return resource->webcoreString();
> > +    }
> 
> please place the opening bracket on a new line per webkit style.  same goes
> for the other functions in this patch.

Hopefully done---I hope we are allowed to keep { on the line of if, at least
that was the case before.
> 
> 
> > +    static AtomicString convertFromV8(v8::Handle<v8::String> v8String, int length) {
> ...
> > +            return AtomicString(inlineBuffer, length);
> > +        } else {
> 
> nit: no need for else after return.
> 
> 
> R- because of style issues.  otherwise, the substance looks good.

Many thanks for review.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list