[Webkit-unassigned] [Bug 21288] Implement HTML5's sandbox attribute for iframes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 16 10:21:45 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=21288





--- Comment #32 from Alexey Proskuryakov <ap at webkit.org>  2009-11-16 10:21:42 PST ---
(From update of attachment 43307)
A couple of minor comments.

> +                     getter raises (DOMException),
> +                     setter raises (DOMException);

This can be just "raises (DOMException)", no need for separate lines for getter
and setter.

> +bool HTMLAppletElement::isJavaEnabled() const
> +{
> +    if (!inDocument())
> +        return false;
> +
> +    if (document()->securityOrigin()->isSandboxed(SandboxPlugins))
> +        return false;
> +
> +    Settings* settings = document()->settings();
> +    return settings && settings->isJavaEnabled();
> +}

<...>

 bool ScriptController::isEnabled()
 {
+    if (m_frame->isSandboxed(SandboxScripts))
+        return false;

I'm not sure if it's so great to have policy checks in simple "isEnabled"
functions. I don't have better names to suggest, but for functions like these,
the names should probably start with "should" or "can".

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list