[Webkit-unassigned] [Bug 26304] [GTK] Add controls for playing html5 video.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 11 00:59:48 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=26304





--- Comment #27 from Benjamin Otte <otte at gnome.org>  2009-11-11 00:59:46 PST ---
disclaimer: I want this in as this stuff mising is really making lots of videos
unusable. So please get these patches in and take my comments as followups.


The control sizes should very likely not be hardcoded, in particular due to
a11y concerns - you want to give people with the large-print gtk theme larger
icons. From a quick look I'm not sure Webkit's core allows reloading CSS yet,
though.

I've also wondered if we could put the icons into the CSS (using
background-image or so) and avoid the whole icon rendering machinery in this
patch, but I don't think that'll work, as the mute button icon depends on
state?

I'm also wondering how well it would work if we were to use gtk themeing
functions to render controls - like gtk_paint_handle() for the slider thumb.
This would get rid of quite some magic numbers while painting. On the other
hand it might look crappy. Also, remaining magic numbers should likely be
queried using gtk style properties, so people can script them.

Shouldn't the static variables be members of the Theme object? You might want
to style different webviews differently. Also, you p[robably don't need to
cache the names of the icons after loading, so the xxxButtonIconName variables
can be local.

Gtk code usually uses GtkIconSet and gtk_icon_set_render_icon() to lookup
icons. This requires a widget pointer, but gets around things like the text
direction magic that the current code is doing, but it only gives you a
GdkPixbuf, not a filename. But that shouldn't matter as we can easily create an
Image from that.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list