[Webkit-unassigned] [Bug 31019] New: Get rid of lengthReceived parameter in ResourceHandleClient::didReceiveData

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 2 10:35:58 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=31019

           Summary: Get rid of lengthReceived parameter in
                    ResourceHandleClient::didReceiveData
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Platform
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: yurys at chromium.org
                CC: timothy at hatcher.name


As fat as I can see this parameter has always the same value as dataLength.
Moreover, at some point it gets passed to
InspectorController::didReceiveContentLength where it is treated as
dataLength(i.e. length of the just received chunk of data).

Here is the example call stack where
InspectorController::didReceiveContentLength is called with. Probably
InspectorController::didReceiveContentLength should be renamed?

>	chrome.dll!WebCore::InspectorController::didReceiveContentLength(WebCore::DocumentLoader * __formal=0x01412200, unsigned long identifier=48, int lengthReceived=5191)  Line 978	C++
    
chrome.dll!WebCore::ResourceLoadNotifier::dispatchDidReceiveContentLength(WebCore::DocumentLoader
* loader=0x01412200, unsigned long identifier=48, int length=5191)  Line 151   
C++
    
chrome.dll!WebCore::ResourceLoadNotifier::didReceiveData(WebCore::ResourceLoader
* loader=0x0433b200, const char * data=0x00e70000, int length=5191, int
lengthReceived=5191)  Line 83    C++
     chrome.dll!WebCore::ResourceLoader::didReceiveData(const char *
data=0x00e70000, int length=5191, __int64 lengthReceived=5191, bool
allAtOnce=false)  Line 254    C++
     chrome.dll!WebCore::MainResourceLoader::didReceiveData(const char *
data=0x00e70000, int length=5191, __int64 lengthReceived=5191, bool
allAtOnce=false)  Line 375    C++
     chrome.dll!WebCore::ResourceLoader::didReceiveData(WebCore::ResourceHandle
* __formal=0x0145b560, const char * data=0x00e70000, int length=5191, int
lengthReceived=5191)  Line 398 + 0x1f bytes    C++
...

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list