[Webkit-unassigned] [Bug 25613] [GTK] Allow to embed any GtkWidget for embed/object

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 26 14:14:46 PDT 2009


gns at gnome.org changed:

           What    |Removed                     |Added
  Attachment #30096|review?                     |review+
               Flag|                            |

------- Comment #14 from gns at gnome.org  2009-05-26 14:14 PDT -------
(From update of attachment 30096)
> +        Implement Widget::setIsSelected for Gtk+ by searching
> +        for a signal of the name widget-set-is-selected and if
> +        this signal is available in the instance we have then
> +        emit it. The signal signature does expect one gboolean
> +        parameter and to return nothing.



> +    g_object_set(platformWidget(), "widget-set-is-selected", isSelected, NULL);

I'd name it 'webkit-widget-is-selected'. I think we want to make the library be
the namespace here, because the widget is selected in the context of our
library; 'set' is something we would expect to see in a method name, not in a
property IMO. With this change, r=me. I'm tagging r+ since Xan already reviewed
and suggested adding webkit-, as well. I don't think he'll opppose to s/set-//.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list