[Webkit-unassigned] [Bug 25503] Add instrumentation framework to WebCore

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 11 15:07:24 PDT 2009


jamesr at google.com changed:

           What    |Removed                     |Added
  Attachment #29934|review?                     |
               Flag|                            |
  Attachment #29934|0                           |1
        is obsolete|                            |
  Attachment #30205|                            |review?
               Flag|                            |

------- Comment #4 from jamesr at google.com  2009-05-11 15:07 PDT -------
Created an attachment (id=30205)
 --> (https://bugs.webkit.org/attachment.cgi?id=30205&action=view)
Addresses some comments and rebases against r43514

This patch addresses the naming issues with AnalysisClient and creates a
separate didFoo() callback instead of the generic finished() callback.  This
way an implementation only interested in a subset of the instrumentation points
could support only the willFoo()/didFoo() pairs they cared about.

This patch also merges up to r43514 and fixes some whitespace/path issues from
the original patch.  I'll address the other comments raised in the bug

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list