[Webkit-unassigned] [Bug 25646] [GTK] onscroll event is never sent

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun May 10 10:59:22 PDT 2009


xan.lopez at gmail.com changed:

           What    |Removed                     |Added
                 CC|                            |xan.lopez at gmail.com

------- Comment #3 from xan.lopez at gmail.com  2009-05-10 10:59 PDT -------
(In reply to comment #2)
> And using this we can ditch the createNativeScrollbar, you mean?
> > -        /*
> > -         * disable the scrollbars (if we have any) as the GtkAdjustment over
> > -         */
> I like the patch in general, it's a good cleanup, but this comment has really
> blown off my mind while I was reading through this code last week, and I
> believe you could perhaps make it clearer at this point why we need to disable
> the scrollbars here:

That's because when you set the adjustments you are telling the View that
you'll handle the scrolling yourself (for example, through a
GtkScrolledWindow), so you want to disable WebKit's scrollbars. I'm not sure
why Holger is removing the comment though...

> > +        m_horizontalAdjustment->setSteps(visibleWidth() / 10.0, visibleWidth() * 0.9, 1);
> > +        m_horizontalAdjustment->setProportion(visibleWidth(), contentsWidth());
> > +        m_horizontalAdjustment->setCurrentPos(scroll.width());
> Xan has done some work recently on the scrolling code to use the WebCore
> constants instead of magic numbers, which I think we should use here as well;
> See r43390.

/me nods (although the WebCore constants are more 'magic numbers' than what we
were using :D)

I'll try to look at this tomorrow!

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list