[Webkit-unassigned] [Bug 24586] maxDeepOffset is confusing and should be removed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 19 15:46:43 PDT 2009


eric at webkit.org changed:

           What    |Removed                     |Added
                 CC|                            |kocienda at apple.com

------- Comment #9 from eric at webkit.org  2009-03-19 15:46 PDT -------
Ok, my current thinking for new names are:

firstPositionInNode and lastPositionInNode become:
// These functions match the 0/maxDeepOffset behavior,
// "deep" is intended to convey that they will prefer the deeper
// of two editing positions corresponding to a node

// lastOffsetInNode will become
int lastNodeOffsetForEditing(node)

// the new functions atStartOfNode and atEndOfNode will become:

Once we have the ability to tell if a position is container relative or
neighbor relative, we can add more specific check functions for just before the
node, just inside the node, etc.

Sound good?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list