[Webkit-unassigned] [Bug 24584] Translucent text rendering on Chromium is broken

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 13 13:12:01 PDT 2009


eric at webkit.org changed:

           What    |Removed                     |Added
             Status|UNCONFIRMED                 |NEW
     Ever Confirmed|0                           |1

------- Comment #4 from eric at webkit.org  2009-03-13 13:12 PDT -------
(In reply to comment #3)
> (In reply to comment #2)
> > (From update of attachment 28591 [review] [review])
> > Why not just call it what it does?  "compositeToParentLayer()" or
> > "restoreContextAndCompositeToParentLayer()"
> > 
> > uninit seems like a really bad name for the function.
> I wanted to stress that it should pair up with init() (and that calling it is
> mandatory if you call init()).

I regretted being so disparaging in my original comment almost as soon as I hit
"commit".  :(

> It's not compositing "to" anything.  It's compositing over the background using
> ClearType, but even that is misleading, since it will get composited again over
> the background using text alpha in the endTransparencyLayer() call.
> Mind if we just call it "composite()"?

composite() is OK.  It's not particularly specific (you'd still have to read
the composite() function to guess at what it did).  It seems it would also make
sense to ASSERT if possible that we'd already composited.  We should probably
be clearing m_savedOnDrawContext after restore now that this is a free
function.  composite() (or whatever you call it) should also be a private
function, since no one should call it except for the destructor.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list