[Webkit-unassigned] [Bug 16401] [GTK] GObject/C DOM binding

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Mar 7 06:52:05 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=16401





------- Comment #183 from jmalonzo at gmail.com  2009-03-07 06:52 PDT -------
(From update of attachment 28381)
Hi Jim

> Index: GNUmakefile.am
> ===================================================================
> --- GNUmakefile.am	(revision 41443)
> +++ GNUmakefile.am	(working copy)
> @@ -31,6 +31,7 @@
>  
>  # Directory for autogenerated sources
>  GENSOURCES := $(top_builddir)/DerivedSources
> +GENSOURCESGOBJECT := $(top_builddir)/DerivedSources/webkit
>  GENPROGRAMS := $(top_builddir)/Programs

Can we rename the build-related GOBJECT wording to GDOM i.e. GENSOURCESGOBJECT
-> GENSOURCESGDOM ?

>  # Script for creating hash tables
> @@ -103,7 +104,8 @@
>  	-I$(srcdir)/JavaScriptCore/ForwardingHeaders \
>  	-I$(srcdir)/JavaScriptCore/parser \
>  	-I$(srcdir)/JavaScriptCore/wtf \
> -	-I$(top_builddir)/DerivedSources
> +	-I$(top_builddir)/DerivedSources \
> +	-I$(srcdir)/WebCore/bindings/webkit

No need to include .../bindings/webkit to the JSC build.

> +webcoregtk_cppflags += \
> +	-I$(top_builddir)/DerivedSources/webkit \
> +	-I$(srcdir)/WebCore/bindings \
> +	-I$(srcdir)/WebCore/bindings/gobject
> +

Please add the lines above to webcoregtk_cppflags in WebCore/GNUmakefile.am

>  nodist_EXTRA_libWebCore_la_SOURCES = \
>  	$(webcore_built_nosources)
>  
> @@ -193,6 +200,7 @@
>  libWebCore_la_LIBADD = \
>  	libJavaScriptCore.la \
>  	libWebCoreJS.la \
> +	libgobject.la \

Let's name the libtool archive to libWebCoreGDOM.la

> +libgobject_ladir = $(prefix)/include/webkit-1.0/webkit
> +libgobject_la_HEADERS = \
> +        $(libgobject_h_api)
> +

Ditto and libwebcoregdom_h_api.Also declare libwebcoregdom_h_api before
libgobject_ladir above.

>  # WebKit
>  webkitgtk_h_api :=
>  webkitgtk_sources :=
> @@ -360,12 +372,14 @@
>  	-I$(srcdir)/WebKit/gtk \
>  	-I$(srcdir)/WebKit/gtk/WebCoreSupport \
>  	-I$(srcdir)/WebKit/gtk/webkit \
> -	-I$(top_builddir)/WebKit/gtk/webkit
> +	-I$(top_builddir)/WebKit/gtk/webkit \
> +	-I$(top_builddir)/DerivedSources

Add DerivedSources/webkit here too.

>  # END WEBKIT GTK+
>  #
>  # Files that will be distributed
> @@ -466,6 +526,7 @@
>  # Build unit test
>  noinst_PROGRAMS += Programs/UnitTests
>  Programs_UnitTests_CPPFLAGS = \
> +	-I$(srcdir)/WebCore/bindings \

I don't think we need to include it.

> @@ -494,7 +555,8 @@
>  	$(webcore_built_sources) \
>  	$(webcore_built_nosources) \
>  	$(webkitgtk_built_sources) \
> -	$(webkitgtk_built_nosources)
> +	$(webkitgtk_built_nosources) \
> +	$(gobject_built_nosources)

gdom_built_sources.

> Index: WebCore/GNUmakefile.am
> ===================================================================
> --- WebCore/GNUmakefile.am	(revision 41443)
> +++ WebCore/GNUmakefile.am	(working copy)
> @@ -1,7 +1,7 @@
>  

>  webcore_cppflags += \
> +	-I$(srcdir)/WebKit/gtk \
> +	-I$(srcdir)/WebKit/gtk/WebCoreSupport \
> +	-I$(srcdir)/WebKit/gtk/webkit \

Do we need to include WebKit here?

>  	-I$(srcdir)/WebCore \
> +	-I$(srcdir)/WebCore/bindings/gobject \
>  	-I$(srcdir)/WebCore/bindings/js \
>  	-I$(srcdir)/WebCore/bridge \
>  	-I$(srcdir)/WebCore/bridge/c \
> @@ -57,6 +61,7 @@
>  	DerivedSources/DocTypeStrings.cpp \
>  	DerivedSources/tokenizer.cpp \
>  	DerivedSources/ColorData.c \
> +	DerivedSources/webkit/webkitdomdummy.c \

This should go to gdom_built_nosources and please add it to BUILT_SOURCES too

> @@ -240,6 +245,14 @@
>  	WebCore/xml/XMLSerializer.idl \
>  	WebCore/xml/XSLTProcessor.idl
>  
> +webcoregtk_sources += \
> +	WebCore/bindings/gobject/webkitbinding.cpp \
> +	WebCore/bindings/gobject/webkitbinding.h \
> +	WebCore/bindings/gobject/WebKitDOMObject.cpp \
> +	WebCore/bindings/gobject/WebKitDOMObject.h \
> +	WebCore/bindings/gobject/webkithtmlelementwrapperfactory.cpp \
> +	WebCore/bindings/gobject/webkithtmlelementwrapperfactory.h 

Please add the sources above to webcoregtk_sources in line ~1730

Kindly rename GOBJECT to GDOM accordingly from here on (i.e. GOBJECT_AUTO_...,
GOBJECT_FIXED_..., GOBJECT_CLASSES, etc...)

> +# Bindings autogenerated in GObject, but not in JS.
> +IDL_BINDINGS_GOBJECT_EXTRA := \
> +	WebCore/html/CanvasPixelArray.idl
> +
> +# Bindings autogenerated in JS, but not in GObject.
> +IDL_BINDINGS_GOBJECT_MINUS := 
> +
> +# All IDL files used for autogeneration in GObject.  We filter out SVG and events for now.

Please add a FIXME re SVG and events ^^^ - as we might need to add it later 

> +gobject_built_nosources := $(GOBJECT_HEADERS_BUILT) $(GOBJECT_SOURCES_BUILT)

This should be _built_sources not _built_nosources.

> Index: WebCore/bindings/gobject/WebKitDOMObject.cpp
> ===================================================================
> --- WebCore/bindings/gobject/WebKitDOMObject.cpp	(revision 0)
> +++ WebCore/bindings/gobject/WebKitDOMObject.cpp	(revision 0)
> @@ -0,0 +1,28 @@
> +/*
> + * Copyright (C) 2008 Luke Kenneth Casson Leighton <lkcl at lkcl.net>
> + * Copyright (C) 2008 Martin Soto <soto at freedesktop.org>
> + * Copyright (C) 2008 Alp Toker <alp at atoker.com>
> + * Copyright (C) 2008 Apple Inc. All Rights Reserved.
> + */
> +

Please include the license header here.

> Index: WebCore/bindings/gobject/webkithtmlelementwrapperfactory.cpp
> ===================================================================
> --- WebCore/bindings/gobject/webkithtmlelementwrapperfactory.cpp	(revision 0)
> +++ WebCore/bindings/gobject/webkithtmlelementwrapperfactory.cpp	(revision 0)
> +#include "webkithtmlelementwrapperfactory.h"

Why are the following lines prefixed with "webkit/"? We're already including
DerivedSources/webkit anyway.

> +#include "webkit/webkitdom.h"
> +
> +#include "webkit/WebKitHTMLAnchorElementPrivate.h"
> +#include "webkit/WebKitHTMLAppletElementPrivate.h"
> +#include "webkit/WebKitHTMLAreaElementPrivate.h"
> +#include "webkit/WebKitHTMLBaseElementPrivate.h"
> +#include "webkit/WebKitHTMLBaseFontElementPrivate.h"
> +#include "webkit/WebKitHTMLBlockquoteElementPrivate.h"
> +#include "webkit/WebKitHTMLBodyElementPrivate.h"

[....]

> Index: WebKitTools/GNUmakefile.am
> ===================================================================
> --- WebKitTools/GNUmakefile.am	(revision 41443)
> +++ WebKitTools/GNUmakefile.am	(working copy)
> @@ -7,8 +7,10 @@
>  
>  # GtkLauncher
>  Programs_GtkLauncher_CPPFLAGS = \
> +	-I$(srcdir)/WebCore/bindings \
>  	-I$(srcdir)/WebKit/gtk \
>  	-I$(top_builddir)/WebKit/gtk \
> +	-I$(srcdir)/WebKit/gtk/webkit \

I don't think we need to add those two above.

> @@ -31,8 +33,10 @@
>  Programs_DumpRenderTree_CPPFLAGS = \
>  	-I$(srcdir)/WebKitTools/DumpRenderTree \
>  	-I$(srcdir)/WebKitTools/DumpRenderTree/gtk \
> +	-I$(srcdir)/WebCore/bindings \
>  	-I$(srcdir)/WebKit/gtk \
>  	-I$(top_builddir)/WebKit/gtk \
> +	-I$(srcdir)/WebKit/gtk/webkit \

Ditto.

Thanks!


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list