[Webkit-unassigned] [Bug 26611] Implement currentThreadStackBase on WinCE

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 22 11:24:20 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=26611


treat at kde.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #31657|review?                     |review-
               Flag|                            |




------- Comment #2 from treat at kde.org  2009-06-22 11:24 PDT -------
(From update of attachment 31657)
> +2009-06-22  Yong Li  <yong.li at torchmobile.com>
> +
> +        Reviewed by NOBODY (OOPS!).
> +
> +        https://bugs.webkit.org/show_bug.cgi?id=26611
> +        Implement currentThreadStackBase on WINCE

You should include the full description of the change here.  As well as
document each new function you are adding where it is non-obvious.  Good to be
concise, but not at the expense of true explanation.

> +inline bool isPageWritable(void* p)

Please do not abbreviate the names of variables.  Spell out the variable using
a good descriptive name.  Err on code readability and maintenance instead of
less typing.

> +    void* sp = (void*)(&lower);
> +    register char* curPage = (char*)((DWORD)sp & ~(pageSize - 1));

Same as above.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list