[Webkit-unassigned] [Bug 25072] CSS21 attribute selectors not dynamic for xml

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 19 07:04:40 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=25072





------- Comment #10 from kai at granus.net  2009-06-19 07:04 PDT -------
> Fix the funny style in:
> if (   ! (attr->isMappedAttribute() && isStyledElement())
> Don't need all those extra spaces.

Was an attempt to make the condition more readable, but of course I will follow
WebKit style.
Should I put it all in one line then?

> My big concern with this change is just performance.  Extra virtual function
> calls being made on every attributeChanged could be an issue.

This can be fixed by refactoring StyledElement::attributeChanged() a little and
removing the tail call of Element::attributeChanged(). If desired, I’ll be
happy to create a patch for this.

Remaining question: Nikolas told me to use document() instead of
ownerDocument() in Element::attributeChanged(), but
StyledElement::attributeChanged() uses ownerDocument(). Which is best?


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list