[Webkit-unassigned] [Bug 27696] Inspector: Console should show completions for the command line APIs
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 28 20:50:05 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=27696
--- Comment #5 from Timothy Hatcher <timothy at hatcher.name> 2009-07-28 20:50:04 PDT ---
(From update of attachment 33549)
> + commandLineAPI = commandLineAPI.reduce(function(a, prop) {
> + if (prop.charAt(0) !== "_")
> + a.push(prop);
> + return a;
> + }, []);
This is pretty fancy. I never really used/liked reduce or map. I think this
would be easier to read as a simple for loop that only appends things to
properties not starting with "_".
I bet it will be less code too!
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list