[Webkit-unassigned] [Bug 26963] Reproducible crash at FontCache::getFontData() when a custom font is used in a pseudo-style

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 6 20:03:34 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=26963


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #32328|review?                     |review+
               Flag|                            |




--- Comment #9 from Darin Adler <darin at apple.com>  2009-07-06 20:03:33 PDT ---
(From update of attachment 32328)
> +bool Element::validatePseudoStyleCache(const RenderStyle* currentStyle, RenderStyle* newStyle)

I don't understand why this function is named "validate" yet returns a boolean.
Typically if functions return a value they are named after the value. I think
the value means "needs to dump the style cache" or something like that, so
validate seems an unhelpful name.

> +    Vector<RenderStyle*, 10> pseudoStyleCache;

I'd prefer a typedef so the magic number 10 isn't repeated here.

> +        if (*newPseudoStyle.get() != *pseudoStyleCache[i]) {

Do you really need the call to get() here? If so, I'm surprised you do.

Otherwise, based on Hyatt's review and my reading of the code, r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list