[Webkit-unassigned] [Bug 23120] Turn on overloaded virtual functions warning in WebCore

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 15 11:37:29 PST 2009


------- Comment #2 from darin at apple.com  2009-01-15 11:37 PDT -------
The first thing we'd need to do would be to change names in JavaScriptCore for
the overloads where functions take either an Identifier or an integer. That
probably affects 10 or so functions in JavaScriptCore and would be a simple
enough change.

The naming I suggest is to use the word "index" in the names. So for
"hasProperty" you could make the version that takes an integer be named

In fact, I think turning this warning on for JavaScriptCore is a separate step
and could almost deserve a separate bug.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list