[Webkit-unassigned] [Bug 23207] Move currentTime() from WebCore into WTF (to use in WTF::MessageQueue::WaitForMessageTimed)
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Jan 10 14:34:23 PST 2009
https://bugs.webkit.org/show_bug.cgi?id=23207
darin at apple.com changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #26560|review? |review+
Flag| |
------- Comment #2 from darin at apple.com 2009-01-10 14:34 PDT -------
(From update of attachment 26560)
> +// Platform note: GTK should use gettimeofday everywhere except WIN, where
Sentence fragment here. Also, I think it might be better to put this comment
after the includes rather than in the middle of them.
> +#if PLATFORM(MAC)
> +double currentTime()
> +{
> + return CFAbsoluteTimeGetCurrent() + kCFAbsoluteTimeIntervalSince1970;
> +}
> +#elif PLATFORM(WIN)
I think some blank lines here would make it easier to read. The per-platform
sections are large enough that a little more vertical whitespace will make it
easier to spot the boundaries.
r=me
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list