[Webkit-unassigned] [Bug 23025] Simplifying DOMTimer lifetime management code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 2 10:58:55 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=23025


darin at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #26300|review?                     |review+
               Flag|                            |




------- Comment #2 from darin at apple.com  2009-01-02 10:58 PDT -------
(From update of attachment 26300)
> -    static_cast<Document*>(context)->removeTimeout(timeoutId);
> +    DOMTimer* timer = static_cast<Document*>(context)->findTimeout(timeoutId);
> +    delete timer;

I personally would like this to just be a one liner without a local variable.

> -    ActiveDOMObject::contextDestroyed();
> +    ActiveDOMObject::contextDestroyed();  // Clears m_scriptExecutionContext.

Is adding this comment really an improvement?

Normally we use one space before the "//".

r=me


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list