[Webkit-unassigned] [Bug 23210] Make it easier for ports to define custom UI for media controls
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jan 9 13:13:05 PST 2009
https://bugs.webkit.org/show_bug.cgi?id=23210
eric at webkit.org changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #26566|review? |review+
Flag| |
------- Comment #3 from eric at webkit.org 2009-01-09 13:13 PDT -------
(From update of attachment 26566)
I would expect this to be either:
const String& or String. I'm not sure what const String would do for you.
The preferred webkit style is no else after return:
+ if (renderer() && renderer()->style()->hasAppearance())
+ return theme()->hitTestMediaControlPart(renderer(), absPoint);
+ else
+ return false;
No need for "o" here:
+ virtual bool hitTestMediaControlPart(RenderObject* o, const IntPoint&
absPoint);
Otherwise it looks fine. If you're a commiter, go ahead and fix the nits and
land, no need to see another patch.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list