[Webkit-unassigned] [Bug 24152] Move the logic to do the unconfirmed message count and pending activity setting from WorkerMessagingProxy to Worker.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 25 23:37:53 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=24152





------- Comment #7 from levin at chromium.org  2009-02-25 23:37 PDT -------
Worker::hasPendingActivity() has changed behavior in this patch.  I think you
want:

   return (!m_askedToTerminate && (m_unconfirmedMessageCount ||
m_workerContextHadPendingActivity)) || ActiveDOMObject::hasPendingActivity();

and it would be nice to put this part "!m_askedToTerminate &&
(m_unconfirmedMessageCount || m_workerContextHadPendingActivity" in a local
bool to make it more readable. 



> for (unsigned i = 0; i < m_queuedEarlyTasks.size(); ++i)
It would be nice to put m_queuedEarlyTasks.size() in a local variable.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list