[Webkit-unassigned] [Bug 16401] [GTK] GObject/C DOM binding

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 18 14:28:30 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=16401


adam at yorba.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #27549|0                           |1
        is obsolete|                            |




------- Comment #179 from adam at yorba.org  2009-02-18 14:28 PDT -------
Created an attachment (id=27762)
 --> (https://bugs.webkit.org/attachment.cgi?id=27762&action=view)
new patch, updated to revision 41018

Here's a new patch.  It includes the following changes:

- We've updated the patch to work with a current WebKit build (r41018, the
latest nightly build).

- Builds with srcdir != builddir now work.

- We've continued to refactor and clean up the code, especially the Perl script
that generates the GObject bindings.  As a result the patch has continued to
shrink: it now weighs in at 3239 lines, a reduction of over 250 lines from the
previous iteration.

- All of Christian's points raised in comments #165-#170 have been addressed. 
Regarding NULL checking as he discussed in #167, we now perform no NULL checks
for attribute setter functions.  This is what I suggested in #178, but we skip
the NULL checks for all types, not just strings.  This makes sense for two
reasons: first, NULL may legitimately be used to remove an attribute, and
second, the existing code doesn't check for NULL when an attribute is set via
setting a GObject property, and so it makes sense to make setter functions
behave the same way.

In this patch DOM classes still use the Gdom prefix.  I'd like to change that
soon.  In comment #171 I suggested three naming possibilities, but I still
don't feel like I've heard a clear consensus as to which is best.  At this
point I don't like #2 because it would lead to odd names in higher-level
language bindings: in particular, in Vala it would lead to classes named
DomDOMObject and DomDOMWindow, for example.  So I vote for either #1 ("WebKit")
or #3 ("WebKitDom", splicing out duplicate instances of the word Dom).  Here's
what class names in Vala would look like with each possibility:

#1: DOMObject, DOMWindow, Element, HTMLElement
#3: DomObject, DomWindow, DomElement, DomHTMLELement

Feedback is welcome!


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list