[Webkit-unassigned] [Bug 23923] HTMLMediaElement should implement mediaPlayerVolumeChanged

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 12 14:16:03 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=23923


simon.fraser at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #27604|review?                     |review+
               Flag|                            |




------- Comment #2 from simon.fraser at apple.com  2009-02-12 14:16 PDT -------
(From update of attachment 27604)
> Index: WebCore/html/HTMLMediaElement.cpp
> ===================================================================

> +    // avoid recursion when the player reports volume changes

Sentence case.

> Index: WebCore/html/HTMLMediaElement.h
> ===================================================================

> +    bool processingMediaPlayerCallback() { return m_processingMediaPlayerCallback > 0; };

Make this |const|

> +    void setProcessingMediaPlayerCallback(bool processing) { m_processingMediaPlayerCallback += (processing ? 1 : -1); }

To avoid the somewhat hard to read 'true', 'false' args, maybe have 2 methods
(begin/end).
Add an assertion to check that m_processingMediaPlayerCallback never goes
negative, and make it signed.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list