[Webkit-unassigned] [Bug 30552] [Symbian] Port ARM traditional JIT Trampolines to RVCT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 18 02:14:59 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=30552





--- Comment #24 from Gabor Loki <loki at inf.u-szeged.hu>  2009-12-18 02:14:58 PST ---
> +        * JavaScriptCore.pri: Extra step to generate RVCT stubs. The 
> +        script generation intentionally executed all the time not just
> +        for RVCT targets.

Is the generation necessary for all platform? Why can not we do the followings?

+symbian: {
+RVCT_STUB_FILES += \
+    jit/JITStubs.cpp
+}
...
+symbian: {
+# GENERATOR 3: JIT Stub functions for RVCT
+rvctstubs.output =
$${GENERATED_SOURCES_DIR}$${QMAKE_DIR_SEP}Generated${QMAKE_FILE_BASE}_RVCT.h
+rvctstubs.commands = perl $$PWD/create_rvct_stubs ${QMAKE_FILE_NAME} -i >
${QMAKE_FILE_OUT}
+rvctstubs.depend = ${QMAKE_FILE_NAME}
+rvctstubs.input = RVCT_STUB_FILES
+rvctstubs.CONFIG += no_link
+addExtraCompiler(rvctstubs)
+}

It would be much better if an rvct symbol can be used instead of symbian.


+#if PLATFORM(ARM_TRADITIONAL)
+#if PLATFORM_ARM_ARCH(5)
+#define BRANCH(reg) bx reg
+#else
+#define BRANCH(reg) mov pc, reg
+#endif
+#endif

Do you really want to support ARMv4 JIT on Symbian? I think I have asked this
question earlier, but I can not recall you answer.
If you want to support it, guard it with an additional COMPILER(RVCT) macro or
move to the next PLATFORM(ARM_TRADITIONAL) && COMPILER(RVCT) section.
(Btw, we should give a better name for #define BRANCH.)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list