[Webkit-unassigned] [Bug 32051] check-webkit-style should check for camelCase variable names

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 4 00:04:00 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=32051





--- Comment #18 from Shinichiro Hamaji <hamaji at chromium.org>  2009-12-04 00:03:59 PST ---
Thanks for your review. I landed my patch with the following changes.

> s/warn/warn about/

Fixed.

> Should there be a \b after return?

Ah, nice catch. Fixed, thanks! I also added a test case for this:

        self.assert_lint('return_t under_score;',
                         'under_score' + name_error_message)

> I'm not sure why this uses the non-group form of parenthesis (and the same
> comment goes for other places especially now that the code uses named groups).
> (The code doesn't need the group, but putting in the ?: just introduces more
> visual noise for me at least.)

This is my habit because using (?:) is slightly faster than (). As I agree this
is less readable and this is inconsistent with other code in this file, I
remove them.

> > +    line = sub(r'^\s*for\s*\(', '', line)
> > +    line, control_statement = subn(r'^\s*(?:while|else if|if|switch)\s*\(', '', line)
> 
> I think qt uses foreach as well but it is probably fine to leave it as
> unsupported for now.

It seems foreach isn't so common. Please let me leave it as is.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list