[Webkit-unassigned] [Bug 32063] New: ScriptController::isEnabled needs to be renamed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 2 04:40:21 PST 2009


https://bugs.webkit.org/show_bug.cgi?id=32063

           Summary: ScriptController::isEnabled needs to be renamed
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: All
        OS/Version: All
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: WebCore JavaScript
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: patrik.j.persson at ericsson.com
                CC: darin at apple.com


During the work with #21288, we realized that the method
ScriptController::isEnabled() has grown to do more than the name says. The name
should reflect what the method does (checks settings, checks sandboxing status,
passes decision to frame loader client): 

bool ScriptController::isEnabled()
{
    Settings* settings = m_frame->settings();
    return m_frame->loader()->client()->allowJavaScript(settings &&
settings->isJavaScriptEnabled() &&
!m_frame->loader()->isSandboxed(SandboxScripts));
}

Darin Adler suggested 'canExecuteScripts' below. Is that OK?

(In reply to comment #51 in bug 21288)
> Loose end for after this lands: ScriptController::isEnabled needs to be
> renamed. It already checked more than just whether JavaScript was enabled.
> Maybe canExecuteScripts is the right name.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list