[Webkit-unassigned] [Bug 28429] Adding Heap profiler page to Web Inspector

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 25 13:58:36 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28429


Timothy Hatcher <timothy at hatcher.name> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #38566|review?                     |review-
               Flag|                            |




--- Comment #15 from Timothy Hatcher <timothy at hatcher.name>  2009-08-25 13:58:35 PDT ---
(From update of attachment 38566)

> +    if (Preferences.heapProfilerPresents) {

This pref should be named heapProfilerPresent.

> +        this.snapshotsListTreeElement = new WebInspector.SidebarSectionTreeElement(WebInspector.UIString("HEAP SNAPSHOTS"), {}, true);

I think you can just use null in place of the {} if you don't have a
represented object.

> +        if (this.snapshotsListTreeElement) this.snapshotsListTreeElement.removeChildren();

This should be on two lines to match our style guidelines.

> +            if (this.snapshotButton) this.snapshotButton.visible = true;

Ditto.

> +            if (this.snapshotButton) this.snapshotButton.visible = false;

Ditto.

> +.heap-snapshot-status-bar-item .glyph {
> +    -webkit-mask-image: url(Images/focusButtonGlyph.png);
> +}
> +

Can you add a FIXME comment about need a new image here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list