[Webkit-unassigned] [Bug 28422] Linking fails with "relocation R_X86_64_PC32 against symbol `cti_vm_throw'"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Aug 23 11:17:19 PDT 2009


--- Comment #4 from Priit Laes (IRC: plaes) <amd at store20.com>  2009-08-23 11:17:18 PDT ---
(In reply to comment #3)
> (From update of attachment 35026 [details])
> Hiding/filtering the symbols is not the right fix here. You might as well do a
> release build. Have you tried forcing  -fPIC in CFLAGS? If that works then we
> need to fix our build scripts to do that automatically.

Tried with CXXFLAGS="-fPIC" CFLAGS="-fPIC" but it didn't work.

I have an alternative patch that seems to fix this issue (at least on my

It seems to be the right approach ( See section 1.5.5 in
http://people.redhat.com/drepper/dsohowto.pdf paper..)

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list