[Webkit-unassigned] [Bug 28269] Inspector: Improve Cookie DataGrid to Show Hidden Data

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 19 13:06:18 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28269





--- Comment #27 from Pavel Feldman <pfeldman at chromium.org>  2009-08-19 13:06:16 PDT ---
This looks so much better from the InspectorController interaction perspective.
Couple of comments below:


> +    m_inspectorController->domAgent()->getCookies(callId, m_inspectorController->m_inspectedPage->mainFrame()->document());

domAgent has private mainFrameDocument() method.

> +    value.set("size", (int)(cookie.name.length() + cookie.value.length()));

not sure if WebKit source base allows casts - leaving for Timothy's advice

> +ScriptArray InspectorDOMAgent::buildArrayForCookies(const Vector<Cookie>& cookiesList)

Here and in other places: I try to maintain same order of methods in .h and
.cpp


>  
> +void InspectorFrontend::didGetCookies(int callId, const ScriptArray& cookies)
> +void InspectorFrontend::didGetCookies(int callId, const String& cookiesString)

There is no overloading in JavaScript, while InspectorFrontend is supposed to
reflect the JavaScript API. I'd either call these differently, or if you are
bound to a single name due the callback nature, I would use didGetCookies(int,
String, ScriptArray) signature and get rid of extra
boolean flag. In javascript it would be if (cookies) { good code } else  {
fallback(cookiesString); }

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list