[Webkit-unassigned] [Bug 28290] Inspector: Resources Search Should Search Only Filtered Resources

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 19 13:00:03 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28290





--- Comment #1 from Joseph Pecoraro <joepeck02 at gmail.com>  2009-08-19 13:00:02 PDT ---
I didn't set that patch as r? because I had some other things that I was
wondering about:

Another developer emailed me with some feedback about the "webkit cookie api". 
He listed a number of good points.  I think I should work on cleaning up and
drafting a good cookie api now, rather then adding it piecewise like I have
been doing.  Some of the suggestions that came out of our email exchange where:

- Change the name of "getRawCookies" to something better like "cookiesList",
and apparently returning a bool is not consistent with other sections.  This
seems more appropriate:

void cookiesList(const Document* document, const KURL& url, Vector<Cookie>&
cookiesList, bool& implemented = false);

- Change the name of "deleteCookie" to "deleteCookieByName" which is more
correct.  I think this is also a good idea.

- It would be nice to prepare for adding support for Creating/Modifying
cookies.  This behavior must already be possible via CookieJar's already
existing setCookies(.., .., String).  I think it would be appropriate to
provide an addCookie convenience function and possibly updateCookieByName.  Or
should these be avoided in favor of specific calls to setCookies?

- He raised a good point as well => "On this topic what is the goal of the
Cookie.h class?  The file didn't contain any comments.  Is it just for the
inspector currently?  Any long term plans?  It would be nice to have a unified
string -> cookie parser for all webkit as it is such as messy job and every
port does it a tiny bit differently."

Any ideas if there could be plans to "unify string cookie parsing" rather then
the current platform specific  mess, or are things too coupled to the network
stacks?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list