[Webkit-unassigned] [Bug 28370] check-webkit-style: add check for 'using std::foo; ' statements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Aug 16 16:31:24 PDT 2009


David Levin <levin at chromium.org> changed:

           What    |Removed                     |Added
  Attachment #34940|review?                     |review+
               Flag|                            |

--- Comment #2 from David Levin <levin at chromium.org>  2009-08-16 16:31:22 PDT ---
(From update of attachment 34940)
> +          'Use \'using namespace std;\' instead of \'using std::%s;\'.' % method_name)

Consider using "" for the outer quotes to avoid the \' because it makes it
easier to read. Like this:

          "Use 'using namespace std;' instead of 'using std::%s;'." %

> diff --git a/WebKitTools/Scripts/modules/cpp_style_unittest.py b/WebKitTools/Scripts/modules/cpp_style_unittest.py
> +            'Use \'using namespace std;\' instead of \'using std::min;\'.'

Consider using "" for the outer quotes to avoid the \'.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list