[Webkit-unassigned] [Bug 28192] run-webkit-tests needs a --exit-after-failures=N option

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 12 16:54:33 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=28192


Mark Rowe (bdash) <mrowe at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #34706|review?                     |review+
               Flag|                            |




--- Comment #7 from Mark Rowe (bdash) <mrowe at apple.com>  2009-08-12 16:54:32 PDT ---
(From update of attachment 34706)
> diff --git a/WebKitTools/Scripts/run-webkit-tests b/WebKitTools/Scripts/run-webkit-tests
> index 1f908ec..003ac8d 100755
> --- a/WebKitTools/Scripts/run-webkit-tests
> +++ b/WebKitTools/Scripts/run-webkit-tests
> @@ -109,6 +109,7 @@ sub writeToFile($$);
>  # Argument handling
>  my $addPlatformExceptions = 0;
>  my $complexText = 0;
> +my $exitAfterNFailures = 0;
>  my $guardMalloc = '';
>  my $httpdPort = 8000;
>  my $httpdSSLPort = 8443;
> @@ -193,6 +194,7 @@ Usage: $programName [options] [testdir|testpath ...]
>    --complex-text                  Use the complex text code path for all text (Mac OS X and Windows only)
>    -c|--configuration config       Set DumpRenderTree build configuration
>    -g|--guard-malloc               Enable malloc guard
> +  --exit-after-n-failures         Exit after the first N failures instead of running all the tests

The help for this flag should indicate that it takes an argument.  Is there any
reason to put it at this point in the help?  Are they in any specific order?

>      countFinishedTest($test, $base, $result, $isText);
> +
> +    my $testsWhichDidNotMatch = $count - $counts{match};
> +    if ($exitAfterNFailures && $testsWhichDidNotMatch >= $exitAfterNFailures) {
> +        print "\nExiting early after $testsWhichDidNotMatch failures.  $count tests run.";
> +        closeDumpTool();
> +        last;
> +    }

$testsWhichDidNotMatch sounds like an array of tests that didn't match. 
Perhaps $failureCount would be a clearer variable name?

r=me

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list