[Webkit-unassigned] [Bug 28128] [Haiku] Modifications on WebCore.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Aug 11 05:55:26 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=28128
--- Comment #9 from Maxime Simon <simon.maxime at gmail.com> 2009-08-11 05:55:25 PDT ---
(In reply to comment #8)
> (In reply to comment #5)
> > (From update of attachment 34417 [details] [details])
> > Why virtual?
> > #if PLATFORM(HAIKU)
> > 175 virtual BBitmap* getBitmap() const;
> > 176 #endif
> >
> > Seems it should be createBBitmap()? Or is it actually a getter? in which case
> > it can be just bitmap(), no?
>
> Well all the other platforms seem to use the same pattern for their native
> bitmap getters:
> […]
>
> Maybe we just need to move ours up with these, I'm not sure why it is down on
> that line.
Even if we keep the "get" prefix, we should rename this function from getBitmap
to getBBitmap (I can't see why I removed the B).
Concerning the virtual, all other ports use it… (Yes I like mimicry.)
> > Why is this needed?
> > #elif PLATFORM(HAIKU)
> > 82 Icon();
> > 8183 #endif
> > please explain in the ChangeLog.
>
> Declaring a default constructor for a currently unimplemented class?
Actually, I didn't check why we have this constructor. :-/
> > Seems like a bad idea:
> > #elif PLATFORM(HAIKU)
> > 127 IntPoint(const BPoint&);
> > 128 operator BPoint() const;
> > 124129 #endif
> > You don't wan implicit conversion of floating point points to integer points.
> >
> > Again, probably bad idea:
> > #elif PLATFORM(HAIKU)
> > 150 IntRect(const BRect&);
> > 151 operator BRect() const;
> > 147152 #endif
> >
> > Again:
> > #if PLATFORM(HAIKU)
> > 119 IntSize(const BSize&);
> > 120 operator BSize() const;
> > 121 #endif
> >
> > (this is all assuming that B* are floating point based).
>
> Yes all the B* classes above use floats. I guess it is better to make all these
> explicit?
I changed this, it will be included in the next patches.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list