[Webkit-unassigned] [Bug 27966] Race condition in the database code
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Aug 7 16:51:42 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=27966
--- Comment #11 from Michael Nordman <michaeln at google.com> 2009-08-07 16:51:40 PDT ---
Yes, much more readable without the style cleanup.
51 typedef Deque<RefPtr<SQLTransaction> > TransactionsQueue;
52 typedef HashMap<String, TransactionsQueue*> TransactionsHashMap;
53 OwnPtr<TransactionsHashMap> m_pendingTransactions;
Can you use an OwnPtr<TransactionsQueue> in the HashMap to avoid any manual
cleanup in the dtor? When the TransactionsHashMap is deleted i think it would
all be properly deleted and deferenced.
Also, can TransactionHashMap be an inline data member instead of held in an
OwnPtr?
91 // Remove 'transaction' from the queue of pending transactions
92 // 'transaction' should always be the first transaction in this queue
93 ASSERT(pendingTransactions->first().get() == transaction);
94 pendingTransactions->removeFirst();
Just checking... are there any circumstanaces where a waiting transaction can
run thru its 'fail' sequence and call releaseLock() early?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list